メインメニュー
掲示板メニュー
XOOPS Cube


XOOPS関連書籍
[掲示板に戻る全部  1-  最新50
1 【バグ潰せ!】バグ不具合報告スレ【仕様です】
Sting_Band
管理人

Sting_Band 2004-6-15 14:40  SITE  [返信] [編集]

バグを発見したらこちらにご報告ください。
セキュリティーに関する重大なものはお問い合わせメールフォームから管理人へ直接知らせて頂いても結構です。


16 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
Sting_Band
管理人

@作者 2004-7-8 2:12  SITE  [返信] [編集]

動作に一貫性が無いので、キャッシュの影響っぽい気がします。キャッシュオン時代の影響がどこかに残ってるのかもしれません。とりあえず可能性が高いものから消していきましょう。

http://xoopsのurl/templates_c
上記フォルダ内にbluesbbのテンプレートキャッシュが生成されているはずです。db%3Abluesbbの名前で始まるキャッシュファイルを全て削除してください。次回アクセス時に自動で再生成されますので削除しても大丈夫です。

念の為にhttp://xoopsのurl/cache の中も見てください。bluesbbの名のつくファイルがもしあれば削除してください。

ここで一旦、症状が改善されるかチェック
これでダメなら次

症状があったユーザーさんにお願いしてブラウザのキャッシュをクリアしてみてください。もしできないようならば、違うブラウザ(症状が出た時以外のブラウザなら何でも良いです)で試してみてください。

これでダメなら、うーん、考えます

p.s
23:00頃にbluesって名前であるサイトにユーザー登録したんですが、もしかしてそこがpaopaoさんのサイトですか?


17 urlの自動リンク
ゲスト

paopao 2004-7-8 9:29  [返信] [編集]

こんにちは。
以下の場合、全てまとめてリンクになってしまうようです。
ブラウザie6 sp1、Netscape7.02で確認しました。

http://www.xxxxxxxxxx.xxx/ このように  リンクになります

http://www.xxxxxxxxxx.xxx/
改行すると問題なし。

前は問題なし http://www.xxxxxxxxxx.xxx/     後ろはダメ
18 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】



paopao 2004-7-8 13:02  [返信] [編集]

>>16

またもや、私の不手際でした。

ユーザーさんが再現条件を調べて下さったのですが、
クッキーを拒否して「直リンク」をクリックした場合に「管理者」になるそうです。

おかしいと思い、スレッドへの直リンクの内容を見てみましたら
http://xoops/modules/bluesbb/viewsread.php?topic=2&sread_id=1245&number=l50&PHPSESSID=xxxxxxxxxxxxxxxxxxxxxx
と、うっかりクッキー情報らしきものまでくっつけておりました。
昨日、今日、xoopsを導入された方は間違ってやっちゃってる可能性もあるんじゃないでしょうか。無いか(^^;)

BluesBBを疑いましたことを謹んでお詫び申し上げます。

引用:
p.s
23:00頃にbluesって名前であるサイトにユーザー登録したんですが、もしかしてそこがpaopaoさんのサイトですか?

いえ、違います。
バカがわかっちゃったので恥ずかしいんですが、プロフィールにurl入れさせてもらいました。
今後ともご指導ご鞭撻宜しくお願いします。
19 Re: urlの自動リンク
Sting_Band
管理人

@作者 2004-7-8 17:12  SITE  [返信] [編集]

引用:
httpで始まる自動リンクに関しては、XOOPSコアで用意されている MyTextSanitizer を利用しています。よって同じクラスを利用しているnewbbを始め、多くのモジュールで同じ状態になります。ですからこの問題を解決するにはXOOPSコアをハックするか、XOOPS開発チームに報告して対応してもらうしかありません。

G's BBSの場合は元スクリプトに自動リンク機能が無かったので、私が自前で作った自動リンク関数を組み込んで対応していたため融通が効いていました。

MyTextSanitizer はbbコード、スマイリー画像表示、タグ除去、自動リンクを一発でやってくれるので便利ではあるのですが・・・う?ん


20 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
Sting_Band
管理人

@作者 2004-7-8 17:55  SITE  [返信] [編集]

引用:

paopaoさんは書きました:
おかしいと思い、スレッドへの直リンクの内容を見てみましたら
http://xoops/modules/bluesbb/viewsread.php?topic=2&sread_id=1245&number=l50&PHPSESSID=xxxxxxxxxxxxxxxxxxxxxx
と、うっかりクッキー情報らしきものまでくっつけておりました。
昨日、今日、xoopsを導入された方は間違ってやっちゃってる可能性もあるんじゃないでしょうか。無いか(^^;)

なるほど??セッションIDごとリンクしちゃってたわけですね。
オートログイン機能のセッションだから永久に生きてるってことになるのかな?そうだとするとヤバヤバですね(大汗)すぐにその直リンク消しましょう。もう消してるとは思うけど。それと以下のURLを参考にPHPSESSIDがURLに含まれないように設定してください。これ大事です。
セッション情報がURLアドレスに自動で付いてしまう
引用:

BluesBBを疑いましたことを謹んでお詫び申し上げます。

いえいえ、こういう問題提議をクリアしていくことがスキルアップに繋がりますから。私も勉強になりました。それにここをROMってる人たちにも参考になったはずです。
引用:
p.s
プロフィールにurl入れさせてもらいました。

おおーそっちのサイトでしたかぁー。サイトの存在は以前から知ってました。G'sBBSからのログ移転されてて凄いなーと思ってました。SITEやMAILを画像化されてるし、新規スレッド作成も画像化して目立つ場所に変更されてるし、BluesBBのデザインを変更しようと考えてる人に大変参考になるサイトだと思います。こちらこそこれからも宜しくお願いします。


21 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

eyes 2004-7-9 22:55  [返信] [編集]

かなり、期待大なモジュールです!
なので細かいところが気になります。
スレッドはthreadな気がする。
22 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

Sting_Band 2004-7-10 0:30  SITE  [返信] [編集]

引用:

eyesさんは書きました:
スレッドはthreadな気がする。

そっちの方向からバグ報告が来るとは思っていませんでした。
ソース内はインチキ英語目白押しだったりするし。
23 i-modoページが謎の文字化け
ゲスト

Galfres 2004-8-15 15:46  SITE  MAIL  [返信] [編集]

 PC用ページは大丈夫なのですが、i-modo用ページで文字化け&何かおかしい表示になってしまいます。

 まず、カテゴリ作成時までは問題なく表示されるのですが、トピックを作成すると、トピック名が文字化けし、カテゴリ名は「??」と表示され、サイト名も日本語部分が「??」と表示されてしまいます。

 文字化けに関してはこちらの設置時のミスかもしれませんが、一部「??」と変換表示されてしまう件にかんしてはまったくの原因不明ですので、サポートお願いします。

 実際の設置URLはこちらです。
24 Re: i-modoページが謎の文字化け
Sting_Band
管理人

Sting_Band 2004-8-16 1:16  [返信] [編集]

i-modo用ページだけが文字化けする場合は、mbstring設定に問題があるということだと思います。

まず、xoopsのphpデバグでエラーを吐かせてみてください。何かしらのエラーが表示されたらそれを教えてください。

php.iniの以下のmbstring設定がどういう設定になっているか教えてください。
mbstring.detect_order
mbstring.encoding_translation
mbstring.func_overload
mbstring.http_input
mbstring.http_output
mbstring.internal_encoding
mbstring.language
mbstring.substitute_character

G's BBS [XOOPS] ではこのmbstring関連のトラブルが多かったので、サポート掲示板にはそれに関する過去ログが豊富です。そちらもご参考にしてみてください。
http://www.bluish.jp/modules/gsbbs/


25 Re: i-modoページが謎の文字化け
ゲスト

Galfres 2004-8-16 18:02  SITE  MAIL  [返信] [編集]

早速の対応ありがとうございます♪

引用:
xoopsのphpデバグでエラーを吐かせてみてください。何かしらのエラーが表示されたらそれを教えてください。


 何もエラーは表示されませんでした^^;

引用:
php.iniの以下のmbstring設定がどういう設定になっているか教えてください。


 すべてコメントアウトされていました^^; このあたりだとするとこちらのサーバーの設定ミスですね^^;
 G'sBBSの過去ログを見て勉強してみます♪ 
26 なおりました。
ゲスト

Galfres 2004-8-17 17:50  SITE  MAIL  [返信] [編集]

過去ログを見て、mbstringの設定を変えたら直りました。

 php.iniファイルの「mbstring」項目に
mbstring.language = Japanese

と入力して、他の「mbstring」設定項目はコメントアウトのままにしました。

 過去ログをしっかり調べずに質問してしまいすみませんでしたm(__)m そして、ありがとうございます♪

 これでやっとCGI掲示板からXOOPSモジュールの掲示板へ移行できます♪
27 投稿するとタイムアウトしてしまう事があります
ゲスト

名無しさん 2004-10-6 23:37  [返信] [編集]

会社のパソコンから投稿をするとpost.phpのところでタイムアウトしてしまう現象が発生します。自宅のパソコンからですと問題なく投稿できます。

ネットワークの違いとしてはIPアドレスが異なるのと、会社はProxy経由で投稿し、自宅は直接投稿するという点です。

ちなみにXOOPSで標準搭載されている掲示板newbbではこの現象は発生しません。自宅、会社ともに問題なく投稿できます。

何が原因なのか私は知識が乏しいので大したことは言えないのですが、以前会社のパソコン経由で投稿するとIPアドレスからドメインが変換できないという問題が発生して悩まされたことがあります(原因は良く分からず今も未解決です)。この問題が何か関係しているのでしょうか?

IPアドレスからドメインが変換できない環境を作るのは難しいので、再現させるのは難しいかと思いますが、何か対策が分かりましたらお手すきのときに対応していただければと思います。

28 Re: 投稿するとタイムアウトしてしまう事があります
Sting_Band
管理人

Sting_Band 2004-10-7 18:36  SITE  [返信] [編集]

>>23
bluesbbで書込めないという場合はHTTP_REFERERを吐かない環境、というのがまず思いつきますが、これはnewbbでも同じことですのでnewbbでは書込めてbluesbbではダメというのがわかりません。その点でProxy経由が問題になるというのもnewbbだとokという点で関連性がよくわかりません。

「post.phpのところでタイムアウトしてしまう現象が発生します」とありますが、具体的にはどういう現象でタイムアウトだと判断されたのでしょうか?何がタイムアウトってなんでしょ?何かしらのエラー表示でも出たのでしょうか?常にタイムアウトするのか、稀にするのかと合わせて教えてください。

phpデバグをオンにして会社から投稿操作すると何かしらエラー表示はでませんでしょうか。出てくれると原因が掴みやすいです。

「IPアドレスからドメインが変換できないという問題」これはあまり関係ないと思います。IPアドレス云々で投稿拒否するような仕組みはモジュールとしては組み込んで無いですし、IPアドレスからホストが変換できない串経由での宣伝書込み業者が以前はこの掲示板にも頻繁に来ていました(今は禁止ワード機能のお陰で来なくなりましたが )。


29 imodeのページの文字化けについて。
ゲスト

tinsukou 2004-10-10 23:01  [返信] [編集]

すみません。上にも書かれているように、
うちのHPでもimodeのページだけ文字化けしています。
うちのHPはaaacafeに設置していまして、PHP.iniの操作はできないようです。
そのようなので、FAQにある「携帯電話ページだけが文字化けする現象の回避方法」の項目をみてやってみたのですが、文字化けしてしまいます。aaacafeは.htaccessやmb_http_output("pass");の使用では回避できないのでしょうか?それとも、うちの設置の仕方がわるいのでしょうか??
また、自分の考えなんですが、
写メールBBSのように、jcode-LE.phpを使って文字化けを回避するというようなことはできないのでしょうか?どなたか、お願いします。。
30 Re: imodeのページの文字化けについて。
Sting_Band
管理人

Sting_Band 2004-10-11 1:30  SITE  [返信] [編集]

こちらの公式サイトスレッド内でAAACAFEについて語られている所がありますので読んでみてください。

どうやらAAACAFEでは、mbsting設定が不充分なのに.htaccess等での変更もできないという仕様らしいですね。こりゃ不味いでしょ。実質mbstingが使えない海外サーバと同じ苦労をするってことですよね。私ならば苦労するまえに引っ越しを考えます。

jcode-LE.phpに関しては使ったことが無いのでわかりません。


31 Re: 投稿するとタイムアウトしてしまう事があります
ゲスト

名無しさん 2004-10-11 23:11  [返信] [編集]

27で投稿したものです。
レスが遅くなり大変申し訳ありません。

タイムアウトの現象ですが、以下詳しく述べます。
特定のネットワークから記事を投稿するとpost.phpがリンクバーに表示され画面は白くなった状態で10秒程度停止し、その後「ページが表示できません」というIEのエラーメッセージが表示されます。
恐らくサーバ側でタイムアウトになっているような気がします。
この現象は100%再現されます。

Sting_Band様のおっしゃるように、私もIPアドレスが変換できないProxyを用いて投稿しても問題なく投稿できるのですが、なぜか会社からのネットワークから投稿するとタイムアウトしていまします。

で、色々原因を調べてみたら、特定のIPだとgethostbyaddrが上手く動作しないみたいです。gethostbyaddrの処理をさせないと正常に書き込めます。もしかしたらIPアドレスからホストへの変換に時間がかかっているのかもしれません。(原因との関係はあまりないかもしれないですが、bluesBBを設置しているサーバはXREAです)

とりあえずpost.phpを以下の様に書き換えて問題を回避しています。これまでこのような問題が出ていないことを考えると、これはは非常にレアなケースなのでしょうね。お騒がせして本当に申し訳ないです。

if($_SERVER["REMOTE_ADDR"]=="xxx.xxx.xxx.xxx"){
  $input_cols .= "'".$myts->makeTboxData4Save($_SERVER["REMOTE_ADDR"])."', ";
}
else{
  $input_cols .= "'".$myts->makeTboxData4Save(gethostbyaddr($_SERVER["REMOTE_ADDR"]))."', ";
}

※xxx.xxx.xxxの部分は特定のIPアドレスです
※上記コード中のスペース部分は投稿上全角スペースを用いてます
32 Re: 投稿するとタイムアウトしてしまう事があります
Sting_Band
管理人

Sting_Band 2004-10-12 1:44  SITE  [返信] [編集]

>>31
なるほど詳しく究明していただきましてありがとうございました。ググってみるとホストが解決できずタイムアウトするということは結構あるみたいですね。gethostbyaddrはホスト名が収得できなかった場合は自動でIPアドレスを代入してくれるので、こういう問題は考えていませんでした。勉強になりました。先に挙げた宣伝業者のProxyの時はこれがうまく機能したのだとおもいます。ではなぜ27氏の会社のProxyはダメなのか・・・

ホスト解決ができそうでできない状態でがんばってる最中に、XREAに時間切れで処理をバサッと切られるってことですよね。これから先は想像ですけど、解決できないのならばサッサと会社サーバ側が「無理です」と宣言してくれると良いのかな?私はネットワークに関して全く分からないのでギブアップです

修正コードは同じような問題に遭遇する他の方の良い参考になると思います。ありがとうございました


33 BluesBB-0.13 にしたら・・・・
ゲスト

教えて君 2005-1-6 10:46  [返信] [編集]

BluesBB使わせていただいております。ありがとうございます。
BluesBB-0.13リリースされたので、アップデートしてみました。

トピックの説明欄のところにタグを記入して画像を表示していたのですが、タグがそのまま表示されるようになってしまいました。
BluesBB-0.13からの仕様でしょうか?
タグが使えるようにするには、どこをいじればよいのか教えてください。お願いします。
34 Re: BluesBB-0.13 にしたら・・・・
ゲスト

riaf 2005-1-6 13:38  SITE  [返信] [編集]

はじめまして。
素晴らしいモジュールをありがとうございます>管理人様

えっと、管理人さんじゃないですが、
>>33
試してないのでわかりませんけど、
ざっとコードを見たかんじでは
viewtopic.php 49行目

$xoopsTpl->assign('topic_info', $myts->displayTarea($topicdata['topic_info'],0,1,1,1,1));

$xoopsTpl->assign('topic_info', $myts->displayTarea($topicdata['topic_info'],1,1,1,1,1));

とすることでHTMLがスルーされそうです。

コードをいじるよりもdisplayTareaが使用されてて、[ img]が使えそうなのでこっちのが簡単かもしれないです
35 Re: BluesBB-0.13 にしたら・・・・
ゲスト

riaf 2005-1-6 16:26  SITE  [返信] [編集]

今気づきました、、、
index.phpの104行目の変更も必要ですね。

何度もすみません^^;
36 Re: BluesBB-0.13 にしたら・・・・
Sting_Band
管理人

@作者 2005-1-6 22:20  SITE  [返信] [編集]

引用:

教えて君さんは書きました:
BluesBB-0.13からの仕様でしょうか?
タグが使えるようにするには、どこをいじればよいのか教えてください。お願いします。

デフォルトではどこからでもタグを通さないように変更しました。例えadminだけしか書き換えれない場所であってもです。

タグを使えるように変更するには、riafさんが示された方法で完璧です。

displayTareaの数字に付いて解説しますと
displayTarea($text, $html = 0, $smiley = 1, $xcode = 1, $image = 1, $br = 1)
となってます。
左から順番に
1番目:htmlタグを通すかどうか。1ならば通す、それ以外は通さない。
2番目: ←smileyを使えるかどうか。0ならば不使用、それ以外だと使用。
3番目:[]で囲まれた独自タグ、xcodeが使えるかどうか。0ならば不使用、それ以外だと使用。
4番目:[img]タグが使えるかどうか。0ならば不使用でaタグに変換。それ以外だと使用。
5番目:改行を許すかどうか。0だと許さない。それ以外だと許す。

#riafさん、フォローありがとうございます


37 Re: BluesBB-0.13 にしたら・・・・
ゲスト

教えて君 2005-1-7 19:05  [返信] [編集]

riafさん、@作者さん、わかりやすい説明ありがとうございます。
助かりました。
さっそく、バージョンアップしなおしてみます。
38 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

名無しさん 2005-1-8 18:21  [返信] [編集]

あるとこは
modules/system/admin.php?fct=preferences&op=showmod&mod=XX
NGです。正しいのは
modules/bluesbb/admin/admin.php?fct=preferences&op=showmod&mod=XX
39 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
Sting_Band
管理人

@作者 2005-1-8 21:19  SITE  [返信] [編集]

modules/bluesbb/admin/index.php
にある「一般設定」へのリンクのことでしょうか?
確かにmymenu機能を上手く使うにはそっちの方が良いですね。
次バージョンで修正します。


40 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

名無しさん 2005-2-12 21:20  [返信] [編集]

近々この掲示板を使うつもりの者です。

他の所でここの掲示板を使っている所を見たのですが、
ウィンドウズXPSP2の
ファイアウォールに引っかかる部分があるようです。
自分はSP2ではないので何処かは分かりませんが、
どなたかSP2にしている方は
お教えいただけたら光栄です。
41 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
Sting_Band
管理人

@作者 2005-2-12 23:19  SITE  MAIL  [返信] [編集]

ファイヤウォールがHTTP_REFERERを遮断しているということはありませんか?
ご確認ください。


42 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

名無しさん 2005-2-14 16:52  [返信] [編集]

初期設定でお知らせメールを「いいえ」にしているのですが、i-modeで書き込みがあると「投稿されました」のメールが来ます。これは仕様でしょうか。
通常の好き込みは自分での書き込みしかしてませんが、メールは来ません。
43 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

名無しさん 2005-2-14 17:00  [返信] [編集]

スミマセン。自己レスです。
携帯はこっちで、制御していたんですね。

>Re: イベント設定はしてないのに管理人にメールが届く

>config.phpをエディタで開くなりしてください。管理人宛のメールをオンオフする設定項目があります。

>define( 'BLUESBB_SENDMAIL' , "off" ) ;
>でよろしいでしょうか?
>このように書き直ししたらメールが来なくなりました

で解決しました。

お騒がせしました。
44 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

capablekid 2005-5-25 17:38  MAIL  [返信] [編集]

BluesBBは、よくできている掲示板だと思います。英語環境で使用する場合に<{$topic_pagenav}>が文字化けしてしまいます。どうもこれは、viewtopic.phpの158から159行の三つのマークが英語に対応できないことによるものだと思います。そのため、この三つのマークを英語表記(Menu of Threads, Previous Topic, Next Topic)としましたが、英語にも対応できるマークがあれば変更していただければと思いました。改良に役立ててください。
45 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
Sting_Band
管理人

Sting_Band 2005-5-27 6:56  SITE  [返信] [編集]

capablekidさんこんにちは

文字化けするのは<{$topic_pagenav}>ではなく、<{$item.posts}>のほうではないでしょうか?
■▲▼のマークのことですよね?
これらのマークは2バイト文字ですので、2バイト表示のできない環境ですと確かに文字化けするでしょう

一番良いのはここも定数化してlanguageファイルで定義してやるということですね。
英語表記は今後のバージョンでcapablekidさんの表記を参考にさせていただきます。


46 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

larkspur 2005-8-20 1:30  SITE  [返信] [編集]

BluesBB、本当に重宝させてもらっています。
今回のバージョンアップで携帯のスレッドストップが有効になったことで、削除人(別の人です)が動きやすくなったみたいです。ありがとうございました。
そこで、もうひとつ携帯関連なのですが、NGワードがPCからの投稿には効くんですが、携帯からはスルーとなっています。
これは「広告防止」が第一目的のNGワード機能ですから問題ないとは思うのですが、私のサイトではそれを利用して「風紀維持」を図っています。
そこで、携帯にもNGワードを適用したいのですが、どのファイルをどのようにいじればいいのか、だいたいでいいのでご教授くれませんでしょうか。
よろしくお願いします。
47 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
Sting_Band
管理人

Sting_Band 2005-8-23 1:58  SITE  [返信] [編集]

>>46
larkspurさんこんにちは。

携帯電話ページの基本設定は、config.php内を書き換えて設定します。
エディタで、config.phpを開いてみてください。


48 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

lakspur 2005-8-25 3:09  MAIL  [返信] [編集]

あ、そうなのか!
すいません、気付きませんでした。
Readmeは隅々まで目を通すべきでした。
49 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

Guym 2005-8-30 19:09  SITE  [返信] [編集]

 初めまして。

 BluesBBを導入させていただきました。
 素敵なモジュール提供をありがとうございます。

 ところで、バグというほどのものではないのですが、Languageに定義しておいてほしい部分を書かせていただきます。

・viewsread.php/121行 「次100」
・i_message.php/174/179行 「次」


50 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
Sting_Band
管理人

Sting_Band 2005-8-31 16:58  SITE  [返信] [編集]

Guymさんこんにちは

>viewsread.php/121行 「次100」
このあたりは定数化すべきものが多く残ってますね。
新バージョンにて対応しておきます。

>i_message.php/174/179行 「次」
携帯電話ページではあえて定数化せず、ソース直書きにしています。
xoopsでは文字コードがEUC-JPですが、携帯電話でのデフォルトがShift_JIS。
この違いによりlanguageファイルにて定数化すると文字化けしてしまうからです。


51 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

Ebith 2005-10-21 1:57  [返信] [編集]

1.0で実装されたトピックの表示順の設定が上手く動作しません。
表示順を設定するとトピック設定画面ではきちんと順番が反映されるものの
実際にフォーラムにアクセスしても表示順は変わらず前のままになってしまいます。
52 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
Sting_Band
管理人

@作者 2005-10-21 14:59  SITE  [返信] [編集]

Ebithさんこんにちは

ご報告ありがとうございます。
確かにバグです。次バージョンで修正します。
お急ぎならば
index.phpの78行目を

$sql = 'SELECT * FROM '.$xoopsDB->prefix('bluesbb_topic').' WHERE'.$where_access.') ORDER BY cat_id, topic_order, topic_id';

としてください。
これで対応できるはず。
後はブロックのカテゴリ別トピックメニュー
これも対応場所をのsqlを
ORDER BY cat_id, topic_order, topic_id
とすれば良いです。


53 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

Ebith 2005-10-21 18:38  [返信] [編集]

ありがとうございました。無事並び替えができるようになりました。
54 書き込み後の表示
ゲスト

Guym 2005-11-8 2:48  [返信] [編集]

 replay.phpで書き込みをしたあと、現在はtopic.phpにもどるようになっていますが、これはthread.phpの表示にもどるようにしたほうが自然に感じられるのですがどうでしょうか?

 threadに対して書き込みしたのに、topic全体を表示されるのは違うような気がします。
 やはり書き込み後は、threadの自分の書き込みが表示されるべきだと思います。

 ご検討くだされば幸いです。
55 投稿順表示時の表示バグについて
ゲスト

名無しさん 2005-11-10 16:26  [返信] [編集]

 たぶん、バグだと思うのでご報告させて頂きます。

 投稿順表示(topic.php)時に、スレッド一覧からスレッド名をクリックしても、そのトピックの最新記事しか表示されません。
 (スレッド単位の投稿順表示がありません)

 よろしくお願いします。
56 新規投稿のリンク先
ゲスト

allure 2005-11-11 18:13  [返信] [編集]

トップページを表示した時に、記事リストの上下に
[新規投稿][スレッド表示]といったナビゲーションが表示されますが、
[新規投稿]のリンク先が上と下では違っているようです。
上の[新規投稿]をクリックすると、問題なく投稿できるのですが、
下の[新規投稿]をクリックすると、
「エラー:トピックが選択されていません」
というエラーが表示されます。

上の方のリンク先は
?/modules/bluesbb/newthread.php?top=3&sty=2

下の方のリンク先は
?/modules/bluesbb/newthread.php?top=3

となっています。

どのファイルを修正すればいいのでしょうか?
57 Re: 新規投稿のリンク先
ゲスト

Guym 2005-11-16 17:28  [返信] [編集]

引用:

allureさんは書きました:
トップページを表示した時に、記事リストの上下に
[新規投稿][スレッド表示]といったナビゲーションが表示されますが、
[新規投稿]のリンク先が上と下では違っているようです。
上の[新規投稿]をクリックすると、問題なく投稿できるのですが、
下の[新規投稿]をクリックすると、
「エラー:トピックが選択されていません」
というエラーが表示されます。

上の方のリンク先は
?/modules/bluesbb/newthread.php?top=3&sty=2

下の方のリンク先は
?/modules/bluesbb/newthread.php?top=3

となっています。

どのファイルを修正すればいいのでしょうか?


 テンプレートのbluesbb_topic.htmlを直せばOKのようです。
 153行目あたり(2つめのnewthread.phpを検索すればわかると思いますが)にstyの引数を与えてないみたいですね。

引用:

<td class="even" nowrap>&nbsp;<a href="<{$bluesbb_url}>/newthread.php?top=<{$topic_id}>&sty=<{$topic_style}>"><{$postnew}></a>&nbsp;|

58 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
Sting_Band
管理人

@作者 2005-11-20 17:26  SITE  [返信] [編集]

>>54
引用:

Guymさんは書きました:
thread.phpの表示にもどるようにしたほうが自然に感じられるのですがどうでしょうか?

意図した動作ですのでバグではありません。
新機能要望スレへどうぞ

>>55
引用:

投稿順表示(topic.php)時に、スレッド一覧からスレッド名をクリックしても、そのトピックの最新記事しか表示されません。

これもバグではなく意図した動作です。
投稿順表示ではスレッドという概念がそもそも必要ありませんよね。
topic.phpでの表示が1つのスレッドとも考えられます。
ブロックや検索からのリンクで矛盾が出ないように、とりあえずthread.phpでの表示も残しています。
投稿順表示をメインで使う場合はトピック設定で「リストディスプレイを表示する」をいいえにした方が良いでしょう。
引用:

(スレッド単位の投稿順表示がありません)

スレッド表示がまさにそれです。

>>56
これは正にバグです。申し訳ありません。
Guymさんが示されている通り、(フォローありがとうございます)

&sty=<{$topic_style}>

が抜けているのが原因です。
次期バージョンで修正します。


59 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

名無しさん 2005-11-21 0:29  [返信] [編集]

引用:

@作者さんは書きました:
>>54
意図した動作ですのでバグではありません。
新機能要望スレへどうぞ

 そうでしたか。
 書き込んだ直後に確認できないのが変だなぁと思っていたので。

 その他の話も了解しました。
60 .
ゲスト

fugafuga 2005-12-25 21:23  [返信] [編集]

内容削除しました。 fugafuga

61 Re: thread.php
Sting_Band
管理人

@作者 2005-12-26 4:50  SITE  [返信] [編集]

fugafugaさん
ご指摘ありがとうございます。
理解しました。

年末年始でまとまった時間が取れると思いますので、そこで修正します。
それまではダウンロードコーナーを閉鎖とさせていただきます。


#問い合わせフォームぶっ壊れてるし・・・
#そろそろ潮時かなぁ・・・


64 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

名無しさん 2008-3-6 1:06  [返信] [編集]

BluesBBでの最近の投稿(スレッド単位&シンプル)の投稿数にずれがあります。
他のブロックではずれていないのですが、BluesBBでの最近の投稿(スレッド単位&シンプル)のブロックだけずれます。
バグでしょうか?
69 Invalid Session
ゲスト

めんたいこ 2008-4-7 17:37  [返信] [編集]

はじめまして。

最近になって投稿したレスやスレを編集しようとすると、
『Invalid Session』というエラー表示がでて、投稿ができません。

BluesBBを入れなおしたり、いろいろ試してみたのですが、直りそうもありません;

+--詳細--+
1、スレやレスの「編集」を押し、編集ページ(edit.php)へ
2、「プレビュー」「投稿」ボタンをおすと、『Invalid Session』というエラーが出る。
3、サイトのトップページへ戻る

この様な順序でエラーが出ます。
どう改善したらいいのか、全く分りません。
どなたかご教示お願いいたします。
74 Re: 【バグ潰せ!】バグ不具合報告スレ【仕様です】
ゲスト

nono 2008-4-21 21:45  [返信] [編集]

search plugin の仕様を満たしてないという報告なのですが、
BluesBB用XOOPS検索-日本語最適化版_plugin バージョン: 0.12
において、本文を表示するを「いいえ」にしても常に本文を表示してしまいます。
80 「BluesBBでの最近の投稿(スレッド単位) 」ブロックについて
ゲスト

tokki 2008-5-14 6:12  [返信] [編集]

「BluesBBでの最近の投稿(スレッド単位) 」ブロックで、既存のスレッドに返信がつくとそのスレッドが一番上に来ますが、その最新の記事を削除してもそのまま一番上にあります。
「New」マークも付いたままです。

スパム投稿などを削除した場合にも新着記事があるようなかんじになってしまうので、ちょっと具合が悪いなと思い報告させていただきました。

よろしくお願い致します。
[掲示板に戻る全部 前100 次100 最新50
BluesBB ©Sting_Band


Copyright(c)2000-2008 by Sting_Band All rights reserved.  |  Design by SevenDays Design