メインメニュー
掲示板メニュー
XOOPS Cube


XOOPS関連書籍

BluesBBサポート板

BluesBB配布スクリプトサポート掲示板です。バグ報告、質問等あればこちらにお願いします。
改造を伴う質問は原則NGです。
ある程度の努力をされている場合、助言程度はしますが丸投げは勘弁してください。

1: インストールしたら。(5)   2: 間違ってバージョンアップしたら(3)   3: 返信時の投稿フォームを各スレッドの最後に。(4)   4: 新機能要望スレ(97)   5: BluesBBの携帯対応について(23)   6: 【バグ潰せ!】バグ不具合報告スレ【仕様です】(65)   7: アクセス制御の仕方を教えてください(7)   8: 携帯ページのタイトル非表示について(4)   9: 名前の表示を変更する方法(8)   10: アクセスレベルの複数グループ指定(3)   11: 一般設定で(8)   12: BluesBB-0.22アップデート時にテンプレート消失(3)   13: インストールできません(3)   14: BluesBBのi-modeでの文字化け(8)   15: 助けてください!!(2)   16: [返信]を消したい(7)   17: 特定ユーザーのみの表示[携帯](5)   18: 新しい投稿の数について(5)   19: 【要注意】 BluesBB用sitemap_plugin の互換性について(1)   20: NEWマークの挿入位置(5)   21: アップデートによる不具合?(3)   22: ブロックの表記方法(3)   23: BLUESBBの投稿を知らせるメールについて(3)   24: インストール後カテゴリ登録ができません(1)   25: BluesBBのIE7対応について他(1)   26: “[返信]”をスレッドの一番下に一つだけ表示させるには?(5)   27: 参照数の表示方法(1)   28: 携帯からのアクセスについて(15)   29: i_post.phpのバグ?(1)   30: 教えてください。(5)  

 新規投稿 | スレッド表示 | ツリー表示 | 投稿順表示 | i-mode | トップ 
« 1 2 (3) 4 5 6 ... 40 »

1 一般設定で
ゲスト

SS 2005-11-21 23:07:00  [返信] [編集]

一般設定で
インデックスリダイレクト

トピックが1つだけだった場合、index.phpを表示しても意味が無いので、
topic.phpへリダイレクトさせます。


の項目がありますが、それを[はい]に設定したあとBluesBBにアクセスしてみると、
真っ白になりなにも表示されません。
[いいえ]にすると通常通り表示できます。
原因はなにかあるでしょうかか・・・?

BluesBBのバージョンは1.02でXOOPS 2.0.13a JP です。
PHPのバージョンは5です。
2 Re: 一般設定で
Sting_Band
管理人

@作者 2005-11-24 3:05:07  SITE  [返信] [編集]

SSさんこんにちは

XOOPSの一般設定でデバックモードを有効「PHPデバグ」にして、エラーを吐かせてみてください。
真っ白だけですと情報が足りませんので、そのエラーから何か原因を推測することができるかもしれません。

そのとき、エラーの中に「Notice」で始まるものがズラーッと表示されるかもしれません。それらは不要ですからお知らせくださらなくても結構です。「Notice」以外で始まるものだけ教えてください。


#PHP5かぁ、これかもなぁ


3 Re: 一般設定で
ゲスト

SS 2005-11-24 20:44:02  [返信] [編集]

えーと、PHPデバグにして試してみましたが、エラーすら吐かず真っ白でした

以前も別モジュールで同じように真っ白になったので、サポートに聞いてみたところ
「このモジュールはPHP5には対応していません」という回答が返ってきました。
今回もおそらく同じ類のものかもしれませんね・・・
非常に残念です
4 Re: 一般設定で
Sting_Band
管理人

@作者 2005-11-27 2:29:25  SITE  [返信] [編集]

手元にphp5の環境が無いので確かめられないのですが
index.phpの18行目付近

while ( $myrow = $xoopsDB->fetchArray($result) ) {
$topic = $myrow["topic_id"];
}



$topicdata = $xoopsDB->fetchArray($result);
$topic = $topicdata["topic_id"];

とするとどうでしょうか?


5 Re: 一般設定で
ゲスト

SS 2005-11-28 0:39:12  [返信] [編集]

引用:
while ( $myrow = $xoopsDB->fetchArray($result) ) {
$topic = $myrow["topic_id"];
}



$topicdata = $xoopsDB->fetchArray($result);
$topic = $topicdata["topic_id"];


上記を試してみましたが、やはり真っ白でした ・・・

6 Re: 一般設定で
ゲスト

Part 2006-3-5 13:02:00  [返信] [編集]

はじめまして。
横から失礼いたします。

私は、以前にbluesbbを使わせていただいてた者です。
今回、XOOPS Cube 2.1 alpha1のコアをインストールしてからbluesbbをアップロードしましたら、下記のエラーが出ました。

Fatal error: Call to a member function on a non-object in /home/stock/www/modules/bluesbb/index.php on line 37
Warning [PHP]: Invalid argument supplied for foreach() in file modules/base/preload/IPbanning/IPbanning.class.php line 9

是非、bluesbbを使わせていただきたいのでご対応宜しくお願いいたします。
7 Re: 一般設定で
Sting_Band
管理人

@作者 2006-3-10 5:01:56  SITE  [返信] [編集]

Partさんこんばんは

エラーはxoops2.0.xでは普通に使えていた関数をCube 2.1では使えないということだと思います。

Cube 2.1はまだ仕様の定まっていないアルファ版ですので、それに合わせるつもりは今のところありません。仕様が定まり二度手間の心配が無くなってからの話になるかと思います。


8 Re: 一般設定で
ゲスト

名無しさん 2006-9-12 18:21:21  [返信] [編集]

bluesbbについてはXoops Cube公式サイトの方でなんか出てるみたいですんで、
見てみたらどーでしょうか。
全部読む 最新50 1-100 板のトップ リロード

1 BluesBB-0.22アップデート時にテンプレート消失
ゲスト

名無しさん 2005-2-12 17:13:46  [返信] [編集]

題名の通り、BluesBB0.22へのアップデート時にDBからBluesBBのテンプレートをすべて消したところ、アップデート操作をしてもBlock用のテンプレートが作成できない状態となってしまいました。
アップロードすれば良いかと思い、試してみたのですが

Template file bluesbb_menu.html does not need to be installed (PHP files using this template file does not exist)

といった具合いにエラーが出てしまい復元できない状態です。
defaultのテンプレートもBlock部分のテンプレートがまったく無い状態になってしまっています。
なんとか直す方法はありますでしょうか?
2 Re: BluesBB-0.22アップデート時にテンプレート消失
Sting_Band
管理人

@作者 2005-2-12 22:13:33  SITE  [返信] [編集]

http://www.bluish.jp/modules/bluesbb/viewsread.php?topic=1&sread_id=63&number=l50#postid577
↑こちらのアナウンスを読まずにアップデートしたのですか?
う?む
本来ならばバックアップデータで、アップデート前に戻って最初から始めて欲しい所ですがバックアップも取ってないということですよね。

templates_c/
このディレクトリ配下にテンプレートのキャッシュが生成されているはずですので、この中のキャッシュファイルを全て削除してみてください。キャッシュファイルは後で自動で再生成されるので消しても問題ないです。が、ねんのためバックアップは取っておいてくださいね。

これでモジュール管理からモジュールのアップデートを行ってください。

これで状態に変化があれば教えてください。


3 Re: BluesBB-0.22アップデート時にテンプレート消失
ゲスト

名無しさん 2005-2-13 2:50:27  [返信] [編集]

お騒がせしました。
モジュールを完全に削除して再インストール後にバックアップしたDBをインポートすることで解決しました。
実はバックアップをしていたので、元に戻したのですが消えたブロックが元に戻らなくなったのが事のはじまりでした。
templates_cも削除してみたのですが、これも効果がなく途方にくれておりました。全くもって原因は不明です。
以前からtemplates_c配下を削除してもテンプレートが反映されない不具合があったので、その関係かもしれません。
ブロックが消えてしまう現象は新しいバージョンのファイルをアップロードした時点で起きました。
古いテンプレートが反映されたままになる予定だったので、ブロックがこの時点で消えてしまうのは予想外でした。
作業手順としては、その後、アナウンスの作業手順に沿ってDBの該当部分を削除したのですが状況は変わりませんでした。
特殊なケースだと思うので参考になるかわかりませんが、同様の現象が起きた方は、この手順で復元できるかもしれません。
お騒がせしてしまい本当にすいませんでした。
全部読む 最新50 1-100 板のトップ リロード

1 インストールできません
ゲスト

pingu 2005-7-30 11:34:59  [返信] [編集]

バージョン0.23がインストールできません。。。

今まで、0.22をインストールしていたのですが、今まで使っていなかったので、アップデートするのではなく、モジュール管理画面からアンインストールして、サーバからもモジュールを消してみました。

その後、0.23をサーバにFTPしてモジュール管理画面でインストールしようとしたのですが、
Table 'xoops_bluesbb' already exists
というメッセージが出てしまい、インストールできません。。

確かに modulesからbluesbbのディレクトリごと消したのですが、他に何をする必要があるか教えてください。。

初歩的な質問ですみません。。
2 Re: インストールできません
ゲスト

nabeyasu 2005-7-31 0:01:43  [返信] [編集]

pinguさん、こんばんは。
引用:
モジュール管理画面からアンインストール

をすればインストール時に作成されたテーブルはきちんと削除されると思うんですけど。
今、自分が思い浮かぶ解決策は、
1)
サーバから削除した0.22をもう一度アップロードしなおしモジュール管理画面からアップデートしモジュール管理画面からアンインストールの手続きをとってみる。
そして0.23をアップロードし新規インストールではだめでしょうか?

2)
phpMyAdminが使える環境でしたら「xoops_bluesbb 」を直接削除してみる。
そして0.23をアップロードし新規インストールしてみる。

いずれにせよ「xoops_bluesbb 」テーブルがデータベースに残っていれば新規インストールでは
Table 'xoops_bluesbb' already exists
エラーがでてインストールできないと思います。

どちらも試していないので、公開中のサイトでしたら識者のレスを待ってみてください。
3 Re: インストールできません
ゲスト

pingu 2005-7-31 0:36:08  [返信] [編集]

nabeyasuさん、ありがとうございます!!
phpMyAdminが使える環境だったので、「xoops_bluesbb 」を直接削除してみたところ、0.23が無事にインストールできました! (感涙)
お恥ずかしながら、phpMyAdminというものに初めてアクセスしました。。
これからは、何かあったらここを疑ってみます。

本当にありがとうございました。
全部読む 最新50 1-100 板のトップ リロード

1 BluesBBのi-modeでの文字化け
ゲスト

名無しさん 2006-3-25 1:21:14  [返信] [編集]

BluesBBはi-modeで見ることができるので便利と思い使い始めたのですが、一部文字化けを起こします。
使っている環境は、
Windows2000
BluesBB 1.03
XOOPS 2.0.7.3
MySQL 4.0.22
PHP Version 4.3.11
PHP.iniの設定は
mbstring.language = Japanese
mbstring.internal_encoding = EUC-JP
mbstring.http_input = auto
mbstring.http_output = pass
mbstring.encoding_translation = On
mbstring.detect_order = auto
mbstring.substitute_cha

です。

なぜか行の先頭に特定の文字が来るとi-modeでは、
なぜか文字化けして 'ξ' のみ表示されたり、その部分が抜けたりします。
(パソコン画面では問題なく表示されています。ただ、パソコン画面でもi-mode表示画面をみると携帯画面と同様に文字化けします)
例えば、
'名古屋'、'認知'などが行の先頭に来ると 'ξ' と表示されます。
'・名古屋'、'・認知' と '・' を入れると正しく表示されます。

こんなことはどなたかありませんでしょうか
対処の仕方があれば教えていただけませんでしょうか?

2 Re: BluesBBのi-modeでの文字化け
ゲスト

froggy 2006-3-25 17:44:32  [返信] [編集]

PHP4.3.11を使っていらっしゃるようなので、おそらくmbstringsの文字コード誤認識のバグによるものではないでしょうか?
私はPHP4.3.11の際に、myAlbum-Pでですが、mbstring.http_output = passの設定で同様のバグに遭遇しました。

php.iniをmbstring.http_output = passをEUC-JPに変更して、i-mode用のディレクトリのみ.htaccessでmbstring.http_output = passとしたらどうでしょうか?
3 Re: BluesBBのi-modeでの文字化け
ゲスト

MASA.H 2006-3-30 22:39:40  SITE  MAIL  [返信] [編集]

ソースを見ると頭で
ini_set("mbstring.language","Japanese");
ini_set("mbstring.http_output","pass");
とやっているので特にi-mode用のディレクトリのみ.htaccessでmbstring.http_output = passとする必要はないようです。

私も文字化けが発生していますが原因はどうやらsjisconvert()のようです。この関数がうまく働かずEUC-JPのままで返しているようです。おかげでPC上のブラウザではエンコードを変えることにより”前次1-新書板”は文字化けしますが本文は読めるようになります。

とりあえず私はfunctions.php内の該当箇所を以下のように編集したところ文字化けが直りました。
function sjisconvert($str){
/*      $code_check = mb_detect_encoding($str);
        if(!eregi("sjis", $code_check) && $code_check != ""){               
 $str = mb_convert_encoding($str, "SJIS", "$code_check");
        }*/
        $str = mb_convert_encoding($str, "SJIS","JIS, eucjp-win, sjis-win,UTF-8");
        return $str;
}
4 Re: BluesBBのi-modeでの文字化け
ゲスト

MASA.H 2006-3-30 23:41:27  SITE  MAIL  [返信] [編集]

追加です。
eucconvert()も同様に修正しないと、携帯で書き込んだものをPCで見たとき文字化けします。
5 Re: BluesBBのi-modeでの文字化け
ゲスト

名無しさん 2006-4-3 0:17:41  [返信] [編集]

ありがとうございます

書き換えてみたのですが、全ての文字がi-modeで文字化しました。

うまく文字コード変換がうまくいっていためでしょうか?
6 mbstringsの文字コード誤認識?
ゲスト

kame 2006-4-3 0:27:04  [返信] [編集]

PHPを4.3.11から4.4.2へ変えてみました

なぜか「認知」、「名古屋」の表示はうまくできるようになりました

今度は題目に「膵炎」という言葉は文字が空白になってしまいました。
「膵膵」、「膵臓」、「膵炎で・・・」と書き込むと問題なく表示ができます。
また「膵炎」とメッセージに書き込むときは文字化けは起こしません

特定の文字の文字コードをうまく認識して変換できていないためなのでしょうか?
7 Re: mbstringsの文字コード誤認識?
ゲスト

froggy 2006-4-4 0:16:16  [返信] [編集]

MASA.Hさん、ありがとうございます。確かに私の
>>2
は、おっしゃる通り必要なかったですね。

kameさん、
変更点は、PHPのバージョンを変更しただけで、php.iniの設定等は
>>1
のままでしょうか?また、my.iniの[mysqld]でのdefault-character-set
の設定は、EUC-JPでしょうか?
私のところの環境は、
Windows XP Pro SP2 + Apache 2.0.55 + MySQL 4.0.26 + PHP4.4.2
+ XOOPS 2.0.13a JP + BluesBB 1.0.3
で、php.iniのmbstrings関係は、
mbstring.language = Japanese
mbstring.internal_encoding = EUC-JP
mbstring.http_input = auto
mbstring.http_output = EUC-JP
mbstring.encoding_translation = On
mbstring.detect_order = auto
mbstring.substitute_character = none
になっています。
この環境では特にハックしなくても、PC・携帯どちらから書き込んだ場合でも文字化けしないようなのですが、kameさんの書き込まれた
題名部分に「膵炎」とのみ書くと確かに空白になりますね。
PCからの書き込みでは空白にはならず、正しく表示されました。
文字コード判定がらみのPHPのバグのようにも思われますが、
どうでしょうね。
8 Re: BluesBBのi-modeでの文字化け
ゲスト

名無しさん 2007-12-7 0:51:41  [返信] [編集]

文字化けで困っているときにこのスレをみて引用:
私も文字化けが発生していますが原因はどうやらsjisconvert()のようです。この関数がうまく働かずEUC-JPのままで返しているようです。おかげでPC上のブラウザではエンコードを変えることにより”前次1-新書板”は文字化けしますが本文は読めるようになります。

とりあえず私はfunctions.php内の該当箇所を以下のように編集したところ文字化けが直りました。

function sjisconvert($str){
/* $code_check = mb_detect_encoding($str);
if(!eregi("sjis", $code_check) && $code_check != ""){
$str = mb_convert_encoding($str, "SJIS", "$code_check");
}*/
$str = mb_convert_encoding($str, "SJIS","JIS, eucjp-win, sjis-win,UTF-8");
return $str;
}
携帯からの表示は文字バケが直りました。しかし携帯からの書き込みが文字化けしてしまいます。ブラウザで文字をエンコーディングでSJISに変えると、携帯から書きこんだ文字は正常になりますが他が文字化けの状態になります。関数がうまく働いていない様子ですが手詰まりなので質問させていただきました。eucconvert()も同様に修正したのですが、働いていないようです。
Windows xp
BluesBB 1.04
XOOPS 2.0.16a-JP
MySQL 4.1.2.1
ヒントでもよいので誰かお願いします
全部読む 最新50 1-100 板のトップ リロード

1 助けてください!!
ゲスト

コワフェール 2005-9-1 4:26:08  MAIL  [返信] [編集]

初めて投稿します。
bluesbbを使用させていただいているのですが、投稿をすると画面が真っ白になってしまいます。

PHPデバグで検証すると下記のエラーが表示されました。


Fatal error: main(): Failed opening required '/home/sites/0000/users/000/web/class/mail/phpmailer/class.phpmailer.php' (include_path='.:/usr/local/lib/php:/usr/local/lib/php/Smarty') in /home/sites/000/users/000/web/class/mail/xoopsmultimailer.php on line 46
Warning [PHP]: main(/home/sites/000/users/000/web/class/mail/phpmailer/class.phpmailer.php): failed to open stream: No such file or directory in file class/mail/xoopsmultimailer.php line 46


Xoops初心者ですよろしくお願いいたします。
2 Re: 助けてください!!
Sting_Band
管理人

@作者 2005-9-19 10:26:33  SITE  [返信] [編集]

XOOPSのメール送信機能に問題がありそうですね。
とりあえず投稿時の「お知らせメール」機能をカットすればその部分の処理を回避できますので試してみてください。


全部読む 最新50 1-100 板のトップ リロード

 新規投稿 | スレッド表示 | ツリー表示 | 投稿順表示 | i-mode | トップ 
« 1 2 (3) 4 5 6 ... 40 »

BluesBB ©Sting_Band


Copyright(c)2000-2008 by Sting_Band All rights reserved.  |  Design by SevenDays Design